phpbrew

MacでのPHP開発はphpbrewが非常に良い
http://www.karakaram.com/mac-install-phpbrew
http://co.bsnws.net/article/95
http://www.karakaram.com/mac-phpbrew-php7

openssl error 対応
https://qiita.com/satoshi-iwaki/items/ed2c267127dcc80baa21

インストール可能一覧

phpbrew known

yosemiteでlibeditエラー。対象から外す

phpbrew install 7.0.28 +default +mysql +pdo +fpm +opcache +intl +iconv -- --with-libedit
phpbrew list
phpbrew switch 5.4.18

一時的な切り替え

phpbrew use 5.4.18

インストール

phpbrew install 7.1.15 +default +mysql +pdo +fpm +opcache +intl +iconv +openssl=$(brew --prefix openssl)
  ↓
[エラー発生]
configure: error: invalid readline installation detected. Try --with-libedit instead.
  ↓
phpbrew install 7.1.15 +default +mysql +pdo +fpm +opcache +intl +iconv +openssl=$(brew --prefix openssl) -- --with-libedit
https://qiita.com/hokutoasari/items/9869ae92966c48db49ed

phpbrew ext install gd